Error en Ubuntu «The Composite extension is not available»

ubuntu-logo.PNGHoy me he puesto a trabajar con mi Ubuntu 7.10, a la que aún estoy moldeando. Y he decidido activar algunas de las opciones gráficas que nos propone para hacer mas animado nuestro escritorio. Esto se encuentra en el menú: Sistema/Preferencias/Apariencia y en la pestaña Efectos Visuales, lógicamente.

Se nos presentan 3 opciones,Ninguno, Normal y Extra, cada cual con mas chorradas visuales. Como a mi no me gusta abusar, he intentado activar la segunda opción, Normal. Pero me ha saltado el error «The composite extension is not available». La verdad es que me ha jodido un poco. Pero gracias a dios, tan solo era cosa de instalar un pequeño archivo/paquete. Con el comando:

sudo aptitude install xserver-xgl

Con este comando y un simple reinicio, este error ya no saldrá, y podremos activar las chorradas gráficas de nuestro Ubuntu. Por cierto, mi tarjeta gráfica es una ATI X800 GTO.

La solución, la encontré en MundoGeek: Solución al Error